Pubblicità

 

Magento supports PHP 5.6, 7.0.2, and 7.0.6 or later

Su Server dedicati Aruba con S.O. Linux Centos 64 bit

Seguendo alcune guide su internet, come ad esempio una guida per installare la traduzione in italiano di Magento in riga di comando mi sono imbattuto su risposta dal server:

Magento supports PHP 5.6, 7.0.2, and 7.0.6 or later. Please
read
https://devdocs.magento.com/guides/v1.0/install-gde/system-requirements.html

eseguendo un comando tipo
php bin/magento setup:static-content:deploy it_IT
oppure
# bin/magento setup:static-content:deploy it_IT

 

Questo errore si verifica perch la shell dove eseguite i comandi php non è una versione supportata.
Anche se in apache (parte web) utilizzate una determinata versione php, questo non vuol dire che nella shell per la inea di comando utilizziate la stessa versione php
Per vedere quale versione php state utilizzando digitate il seguente comando
php - v
otterre la risposta della versione php in uso ad esempio

PHP 5.4.16 (cli) (built: Apr 12 2018 19:02:01)
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2013 Zend Technologies
    with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.c

 

Potete utilizzare altre versioni di php da linea di comando
quelle disponibili le trovate in
/opt/plesk/php/

per cambiare la versione del php da utilizzare scrivete da linea di comando (ad esempio come super user)
echo “alias php=’/opt/plesk/php/7.0/bin/php’” >> ~/.bashrc
dove 7.0 è la versione desiderata da utilizzare (cambiarla a piacimento tra quelle disponibili)
uscite da Super user con il comando
exit
riloggatevi come super user
e ora digitate il comando per interrogare sulla versione php utilizzate
php -v
nel caso nostro la ripsosta sarà

PHP 7.0.32 (cli) (built: Sep 14 2018 13:16:36) ( NTS )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
    with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v10.2.1, Copyright (c) 2002-2018, by ionCube Ltd.
    with Zend OPcache v7.0.32, Copyright (c) 1999-2017, by Zend Technologies

ora possiamo usare inostri comandi php per magento.

 

 

 

 

Lascia un commento

Il tuo indirizzo email non sarà pubblicato.

Pubblicità